Bluetoothのバージョンが違っていても使えますか。

使用できます。ただし、古いバージョンに合わせて接続されるため、一部機能が制限される場合があります。
(例)Ver.4.2の製品とVer.3.0の製品の場合→Ver.3.0で接続されます。
この場合、Ver.4.0以降に搭載されているBluetooth Low Energy※1を使用する機能が使用できなくなります。
※1 低消費電力の通信モード 

この回答はお役に立ちましたか?